Modern server architectures and configurations are managed in many different ways. Some people still put new software somewhere in opt manually for each server while others have already jumped on the configuration management train and fully automated reproducible setups.

Graylog can be installed in many different ways, allowing you to pick whatever works best for you.

This section describes the many ways to install Graylog and aims to help you choose the one that best fits your needs.

Choose an Installation Method

System Requirements

Warning: We caution you not to install or upgrade Elasticsearch to 7.11 or later! It is not supported. Doing so will break your instance!

The Graylog server application is compatible with the following operating systems:

  • Debian 10 and 11
  • Ubuntu 22.04

  • RHEL/CentOS/AlmaLinux/Rocky Linux 9

Also required is one of the following databases:

WarningGraylog 5.0 only supports v7.10.2 of Elasticsearch! We recommend you use OpenSearch 2.x as your data node to support Graylog 5.0.